В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
victoriaanna1
victoriaanna1
27.10.2021 19:08 •  Информатика

Решите с pascal 1. Найти сумму чисел, которые оканчиваются на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа.
2. Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа.
3. Пользователь вводит два целых числа A и B (А 4. Даны натуральные числа от 101 до 321. Напечатать те из них, которые делятся БЕЗ ОСТАТКА на 4, но не делятся на 6.

Ответ:
14andrew
14andrew
14.06.2021 18:17

1)

var

n,x,s,i : integer;

begin

s:=0;

write('Введите n: '); read(n);

for i:=1 to n do

begin

write('X - ', i, ' = '); read(x);

if x mod 10 = 9 then

s:=s+n;

end;

writeln('Сумма с 9 на конце = ', s);

end.

2)

var

n,i,max,x : integer;

begin

max:=0;

write('Введите n: '); read(n);

for i:=1 to n do

begin

if (x > max) and (x mod 5 = 0) then

max:=x;

write('X - ',i,' = '); read(x);

end;

writeln('Максимальное, кратное 5 = ', max);

end.

3)

var

a,b,i : integer;

begin

write('a = '); read(a);

write('b = '); read(b);

for i:=a to b do

begin

if (i mod 4 = 0) and (i mod 6 <> 0) then

writeln(i);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?