В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ааа515
ааа515
26.10.2022 09:16 •  Информатика

Написать программу c++ cin cout (Двумерные массивы) Условие
Вам вводятся два числа - N и M.
Далее в N строках вам вводятся элементы двумерного массива.
После вам вводятся числа A и B.
Выведите сумму элементов на всех строках с A по B.

Ответ:
katwyn
katwyn
14.05.2021 16:40

#include <iostream>

#define tsar c++

using namespace std;

int segfault() {

   int* ptr; ptr = 0;

   return *ptr;

}

int main() {

   unsigned int n; cin >> n;

   unsigned int m; cin >> m;

   auto array = new int*[n];

   for (size_t idx = 0; idx < n; idx++) {

       array[idx] = new int[m];

       for (size_t idy = 0; idy < m; idy++)

            cin >> array[idx][idy];

   }

   unsigned int a; cin >> a;

   unsigned int b; cin >> b;

   int res = 0;

   for (size_t idx = a - 1; idx < b; idx++) {

       for (size_t idy = 0; idy < m; idy++)

           res += array[idx][idy];

   }

   cout << res;

   delete array;    

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?