В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
privetikivsem
privetikivsem
24.04.2021 19:39 •  Информатика

1.заменить все положительные элементы массива на 99. 2.составить программу, вычисл. произведения положительных и сумму отрицательных элементов.

Ответ:
Асия2008
Асия2008
01.10.2020 10:37
Pascal:
1)
const n = 10;
var a:array [1..n] of integer;
     i:integer;
begin
  randomize;
  for i:=1 to n do
   begin
    a[i]:=random(21)-10;
    write (a[i]:3);
   end;
  writeln;
  for i:=1 to n do
   begin
    if a[i]>0 then a[i]:=99;
    write (a[i]:3);
   end;
  writeln;
end.

2)
const n = 10;
var a:array [1..n] of integer;
     p,s,i:longint;
begin
  p:=1;
  s:=0;
  randomize;
  for i:=1 to n do
   begin
    a[i]:=random(21)-10;
    if a[i]>0 then p:=p*a[i] else
     if a[i]<0 then s:=s+a[i];
    write(a[i]:3);
   end;
  writeln;
  writeln ('Proizvedenie: ',p);
  writeln ('Summa: ',s);
end.

C++:
1)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
  int a[10];
  srand (time(NULL));
  for (int i = 0; i<10; i++)
  {
    a[i] = rand()%20-10;
    cout <<a[i] <<" ";
    if (a[i]>0)
      a[i] = 99;
  }
  cout <<endl;
  for (int i = 0; i<10; i++)
    cout <<a[i] <<" ";
  cout <<endl;
  return 0;
}

2)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
  int a[10];
  int p = 1,s = 0;
  srand (time(NULL));
  for (int i = 0; i<10; i++)
  {
    a[i] = rand()%20-10;
    cout <<a[i] <<" ";
    if (a[i]>0)
      p*=a[i];
    else if (a[i]<0) s+=a[i];
  }
  cout <<endl;
  cout <<"Summa: " <<s <<endl
         <<"Proizvedenie: " <<p <<endl;
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?