В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
marimuravskap08uv0
marimuravskap08uv0
16.06.2020 17:45 •  Информатика

Написать решение паскаль в algo. 1) для заданного x вычислить значение функций: y= 1) корень из x в квадрате, если x=2 2) "нет решений", если x=0 3) 3x в квадрате минус 5, если x=3,4,5,6. 2) - составить алгоритм и программу написать программу, которая определяет по последней цифре числа последнюю цифру его квадрата написать полное решение программы, заранее

Ответ:
jija2002
jija2002
20.06.2020 05:59
1)
Var x:integer;
Begin
 write('x=');
 readln(x);
 if x=2 then writeln('y=',sqrt(x*x))
  else
   if (x>=3)and(x<=6) then writeln('y=',(3*x*x-5))
    else writeln('Решений нет');
End.

2)
Var x:integer;
Begin
 write('x=');
 readln(x);
 x:=x mod 10;
 writeln('Последняя цифра квадрата числа: ',x*x);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?