В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Нікіта1111
Нікіта1111
20.12.2020 02:00 •  Информатика

1.написать программу , которая вычисляет произведение цифр к-значного числа. 2. пусть элементами равносторон.треугольника являются : сторона a, высота h, площадь s, вписанная окружность r, описанная окружность r. составить программу , которая по заданному номеру и значению элемента , вычисляла бы значения всех остальных элементов

Ответ:
Маджидия
Маджидия
01.10.2020 10:37
Решу только первую задачу.

const k=?; {Вместо "?" подставить любое значение k} 
Var x,i,s:integer;
Begin
 write('x=');
 readln(x);
 s:=1;
 for i:=1 to k do
   begin
    s:=s*(x mod 10);
    x:=x div 10;
   end;
  writeln('s=',s);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?