В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sergiomac1108
sergiomac1108
17.09.2022 07:10 •  Информатика

На турбопаскале: хотябы пару штук 1.дано натуральное число найти сумму и произведение первых двух цифр. 2.дано n-значное натуральное число. правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа. 3.составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.

Ответ:
fghtgxbvdrzra
fghtgxbvdrzra
20.06.2020 03:28
Program  Kasyanova98_1;
uses crt;
var n,nt,p:integer;
  begin
  writeln('***   Alphaues is thinking...   ***');
  write('Ok, введите натуральное число N = ');
  readln(n);
  nt:=n;
  while nt>=10 do
    begin
      p:=nt;
      nt:= nt div 10;
    end;
  writeln('Cумма первых двух цифр числа ',n,' равна ',(p div 10)+(p mod 10));
  writeln('Произведение первых двух цифр числа ',n,' равно ',(p div 10)*(p mod 10));
end.

Program  Kasyanova98_2;
uses crt;
var n,nt,sum,kw,temp:integer;
  begin
  writeln('***   Alphaues is thinking...   ***');
  write('Ok, введите натуральное число N = ');
  readln(n);
  nt:=n;
  sum:=0;
  kw:=1;
  while nt>=1 do
    begin
    temp:=nt mod 10;
    sum := sum + temp;
    kw:=kw * temp;
    nt := nt div 10;
  end;
  if kw*kw=sum*sum*sum then
      writeln('Квадрат произведения цифр числа ',n,' равняется кубу суммы его цифр')
    else
writeln('Квадрат произведения цифр числа ',n,' НЕ равняется кубу суммы его цифр');
end.

Program Kasyanova98_3.1;
uses crt;
const n=10;
var
  x,y:integer;
begin
  writeln('');
  writeln('*                   ТАБЛИЦА УМНОЖЕНИЯ                  *');
  writeln('');
  write('*    * ');
  for y:=1 to n do
    begin
      write(y:2);
      if y<n then write(' | ')
      else      writeln(' * ');
    end;
  writeln('');
  for x:=1 to n do
    begin
      write('* ',x:2, ' * ');
      for y:=1 to n do
         begin
          write(x*y:2);
          if y<n then write(' | ')
        end;
        if x*y<100 then writeln(' * ')
                   else writeln('* ');
        if x<10 then writeln('++')
                else writeln('');
    end;
end.

Program Kasyanova98_3.2;
uses crt;
const n=10;
var
  x,y:integer;
begin
  writeln('');
  writeln('*                   ТАБЛИЦА СЛОЖЕНИЯ                   *');
  writeln('');
  write('*    * ');
  for y:=1 to n do
    begin
      write(y:2);
      if y<n then write(' | ')
      else      writeln(' * ');
    end;
  writeln('');
  for x:=1 to n do
    begin
      write('* ',x:2, ' * ');
      for y:=1 to n do
         begin
          write(x+y:2);
          if y<n then write(' | ')
        end;
        if x+y<100 then writeln(' * ')
                   else writeln('* ');
        if x<10 then writeln('++')
                else writeln('');
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?