В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Lolycat
Lolycat
07.08.2020 10:38 •  Информатика

Напишите программу на паскале, которая в последовательности натуральных чисел определяет
количество чисел, кратных 7. Программа получает на вход количество чисел в
последовательности, а затем сами числа. В последовательности всегда имеется число,кратное 7. ( while или repeat)

Ответ:
отличникиии
отличникиии
21.04.2021 18:20

var a:array[1..1000] of integer;  

sum,n,i:integer;  

begin  

sum:=0;  

writeln('Введите количество чисел');  

read(n);  

writeln('Введите числа');  

for i:=1 to n do begin  

read(a[i]);  

if (a[i] mod 7=0) and (a[i] mod 10=4)then sum:=sum+a[i];  

end;  

writeln('Сумма элементов кратных 7 и оканчиваюшихся на 4 = ',sum);  

end.

Объяснение:

пойдет?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?