В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
polisorb2
polisorb2
17.12.2021 07:15 •  Информатика

Вы ввели трехзначное число. затем ввели любую цифру. составьте программу, определяющую, есть ли в этом числе данная цифра.

Ответ:
ТуристАртемий
ТуристАртемий
19.06.2020 09:15
Pascal:
var n,m:longint;
      f:boolean;
begin
  write ('Decimal: ');
  readln(n);
  write ('Number: ');
  readln (m);
  f:=true;
  while (n<>0) do
  begin
    if ((n mod 10)=m) then
      begin
       f:=true;
       break;
      end;
    n:=n div 10;
  end;
  if f then writeln ('YES!') else writeln ('NO');
  readln;
end.

C++:
#include <iostream>
using namespace std;

int main()
{
  int n,m;
  bool f = false;
  cout <<"Decimal: ";
  cin >>n;
  cout <<"Number: ";
  cin >>m;
  while (n!=0)
  {
    if ((n%10)==m)
    {
      f = true;
      break;
    }
    n/=10;
  }
  if (f)
    cout <<"YES!" <<endl;
  else cout <<"NO!" <<endl;
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?