В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tanya22rus
Tanya22rus
17.12.2021 07:15 •  Информатика

Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b ( от1 до 100). нужно составить 1- с циклом с пред условием, 2 - с циклом с пост условием

Ответ:
SofaBai
SofaBai
19.06.2020 09:12
1)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
for a:=1 to 99 do begin
if a mod b = 0 then
sum:=sum+a;
end;
writeln(sum);
end.

2)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
repeat 
if a mod b = 0 then
sum:=sum+a;
inc(a);
until a=100
writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?