В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
арсен2000
арсен2000
26.04.2023 09:24 •  Информатика

Цикл с параметром.pascale.нужно написать программу. определить количество чисел, кратных 5, среди n чисел, заданных случайным образом в диапозоне от -50 до 50.

Ответ:
натали524
натали524
01.10.2020 10:00
Const nmax = 30;
var a:array [1..nmax] of integer;
      i,k,n:integer;
begin
  randomize;
  k:=0;
  repeat
    write ('N = ');
    readln (n);
  until n in [1..nmax];
  for i:=1 to n do
    begin
      a[i]:=random(101)-50;
      writeln (a[i]);
      if a[i] mod 5 = 0 then inc(k);
    end;
  writeln ('Kol-vo: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?