В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
хюрем3
хюрем3
26.04.2023 09:24 •  Информатика

Составить программу (паскаль) построения на экране n прямоугольников разного цвета, расположенных хаотично.

Ответ:
zukara95
zukara95
19.06.2020 06:41

uses graph;
var n,i,x,y,height,width:integer;
procedure init;
var gd,gm:integer;
begin
  gd:=vga;
  gm:=vgahi;
  initgraph (gd,gm,'');
end;
procedure error;
begin
  closegraph;
  writeln ('error!');
end;
begin
  write ('N = ');
  readln (n);
  randomize;
  init;
  if graphresult = 0 then
    begin
      for i:=1 to n do
        begin

          setcolor (random(14)+1);
          x:=random(640);
          y:=random(480);
          height:=random(91)+10;
          width:=random(101)+20;
          rectangle (x,y,x+width,y+height);
        end;
    end else error;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?