В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anastasia9311
Anastasia9311
03.08.2020 12:07 •  Информатика

Написать программу и блок схему. вот : даны две точки: а(x1; y1) и b(x2; y2) нужно составить программу определяющую, какая из точек находится ближе к началу координат.

Ответ:
Tina05
Tina05
19.06.2020 06:10
Var x1,y1,x2,y2,d1,d2:real;
begin
  write ('X1 = ');
  readln (x1);
  write ('Y1 = ');
  readln (y1);
  write ('X2 = ');
  readln (x2);
  write ('Y2 = ');
  readln (y2);
  d1:=sqrt(sqr(x1)+sqr(y1));
  d2:=sqrt(sqr(x2)+sqr(y2));
  if d1<>d2 then write ('К началу координат ближе ');
   if d1>d2 then writeln ('вторая точка') else
    if d2>d1 then writeln ('первая точка') else
      writeln ('Обе точки равноудалены друг от друга');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?