В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
artemivanyk200
artemivanyk200
22.10.2021 04:51 •  Информатика

Напишите программу на с++ без динамических массивов с функцией Наименьшее общее кратное (НОК) двух натуральных чисел – это наименьшее число, которое делится нацело на оба исходных числа. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

Входные данные
Входная строка содержит два натуральных числа, разделённые пробелом – a и b .

Выходные данные
Программа должна вывести одно натуральное число: НОК заданных чисел.

Ответ:
makskatya20
makskatya20
11.04.2021 19:50

надеюсь правильно

Объяснение:

#include <iostream>

using namespace std;

int gcd(int a, int b) {

   return (a == 0) ? b: gcd(b % a, a);

}

 

int main() {

   int n, m = 0;

   cin >> n;

   for (int i = 0; i < n; i++) {

       int a;

       cin >> a;

       m = gcd(m, a);

   }

   cout << m;

   return 0;

}

0,0(0 оценок)
Ответ:
sdgsdgsdgsdgsdg228
sdgsdgsdgsdgsdg228
11.04.2021 19:50

1

2

3

4

5

6

7

8

9

10

11

var m,n,pr:word;

begin

read(m,n);

pr:=m*n;

while m<>n do

begin

if m>n then m:=m-n

else n:=n-m

end;

write(pr div m)

end

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?