Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
1NICOLAS1
12.03.2022 19:10 •
Информатика
Написать программу в free pascal: дано целое число неизвестной размерности. найти сумму цифр его составляющих.
Ответ:
vddrobysheva
01.10.2020 09:53
Var n,sum:integer;
begin
sum:=0;
write ('N = ');
readln (n);
while n <> 0 do
begin
sum:=sum+n mod 10;
n:=n div 10;
end;
writeln ('Summa: ',sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
тати31
09.02.2022 10:39
ЯЗЫК ПРОГРАММИРОВАНИЯ ДЕЛФИ ОДНО МАЛЕНЬКОЕ ЗАДАНИЕ ЗА ОЧЕНЬ НУЖНО!...
Fatimochkaananas
23.02.2021 21:50
Движение робота по линии. Урок 2 Изучи предложенное изображение и определи условие, при котором робот проедет вперед одиноборот.ответы:1)при определении цвета кроме красного,2)при...
romaroma6
31.07.2020 07:12
ответить на вопросы Как использовать датчик цвета в организации движения робота?Как отличить датчик цвета от других датчиков?Как использовать разные режимы датчика цвета при движении...
alexalex251003
20.01.2022 00:54
Используя средства языка программирование , составить таблицу соответствия больших и малых букв алфавита коду asc||...
cJKYSIRJH
19.09.2022 07:38
Яка матиматична операція найвища за пріорететом...
Надюфка1997
20.09.2022 05:25
Программа на c++ напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные...
Asker1231
01.04.2020 22:14
Задание №2. Определить сказуемое (следите за полнотой значения сказуемого); чем оновыражено?Сейте разумное, доброе, вечное.Ещё я долго буду петьа) По реке и кустам начинает шуметь...
Peregudovapolina
01.04.2020 22:14
На своей машине Василий с отцом отправились на ярмарку в соседний город и со скоростью 70 км/ч добрались туда за 2 ч. Возвращались по другому пути, чтобы заехать к бабушке в деревню....
kiranay2007
02.12.2021 01:29
Сколько будет:21см 8мм-14см 1мм=???...
Santastiff666
22.08.2022 02:56
Обчисліть перший член геометричної прогресії (b), якщо b4-b2 =2, b7-b5 =54...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
sum:=0;
write ('N = ');
readln (n);
while n <> 0 do
begin
sum:=sum+n mod 10;
n:=n div 10;
end;
writeln ('Summa: ',sum);
end.