В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MAN1337228
MAN1337228
16.07.2022 03:19 •  Информатика

Напишите программу, которая выводит в порядке возрастания все корни уравнения ax3+bx2+cx+d=0 на отрезке [0,1000]. Если решений к данному уравнению не существует, то ничего выводить не нужно. Вводные данные: на четырех строках даны числа коэффициенты уравнения A, B, C и D.
Исходные данные: на разных строках вывести все корни уравнения, если таковые существуют.
Пример 1
Ввод:
1
-6
8
0

Вывод:
0
2
4

Ответ:
Алика2018
Алика2018
08.05.2021 10:31

Если все коэффициенты и корни целые, то так:

a = int(input('a: '))

b = int(input('b: '))

c = int(input('c: '))

d = int(input('d: '))

   

for x in range(0, 1001):

   if a*x**3 + b*x**2 + c*x + d == 0:

       print('Корень: ' + str(x))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?