В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
frankinshtein228
frankinshtein228
12.11.2020 14:39 •  Информатика

массив содержит чёткое количество элементов напишите программу которая сортирует первую половину массива по возрастанию а вторую по убыванию каждый элемент должен остаться в своей половине питон​

Ответ:
лольтоаш
лольтоаш
07.05.2021 09:10

Python

from random import randint

n=int(input('Введите количество элементов массива : '))

if n%2!=0:

 n=n+1

a=[0]*n

for i in range (0, n):

 a[i]=randint(1,100)

 

print(a)

i=0

k=0

# сортируем первую часть массива по возрастанию

while i< n//2-1:

 if a[i]>a[i+1]:

     k=a[i]

     a[i]=a[i+1]

     a[i+1]=k

     i=-1

 i +=1

# сортируем вторую часть массива по убыванию

while i < n-1:

 if a[i]<a[i+1]:

     k=a[i]

     a[i]=a[i+1]

     a[i+1]=k

     i=n//2-1

 i +=1

 

print(a)  


массив содержит чёткое количество элементов напишите программу которая сортирует первую половину мас
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?