Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
bigmama2
16.09.2020 16:38 •
Информатика
На завтра нужно ! ) напишите программу, вычисляющую сумму только тех из введенных чисел, которые делятся нацело на 6.
Ответ:
miravolkova19
18.06.2020 23:57
Var
a,i,n,s:integer;
begin
write('Сколько чисел будет введено? - ');
readln(n);
s:=0;
for i:= 1 to n do
begin
readln(a);
if a mod 6=0 then s:=s+a;
end;
writeln('Сумма чисел кратных 6 = ', s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
aiganymAbz
16.09.2021 20:23
Напишите в языке Паскаль две звезды пятиконечных по такому принципу- program dima; uses GraphABC; procedure Sn(x,y:integer); begin line(x,y,x+100,y+100); line(x+100,y,x+25,y+75);...
алгебра171
11.04.2022 18:21
В массиве А из 20 целых чисел найти сумму тех элементов, которые кратны заданному числу К (число К запрашивать с клавиатуры). Элементы массива в диапазоне от 10 до...
Машаrobotg
29.08.2020 00:14
Сколько цифр 1 в двоичном представлении десятичного числа 12...
незнайка1186
17.03.2023 02:07
98 7 класс. тест « информационные процессы» №1. информационными процессами являются(выпиши в бланк ответов): хранение информации передача информации поиск информации...
mnl39
28.08.2021 08:51
Нужно написать программу на c++ даны а, x, y. вычислить m, n, если:...
anyaannaegorova
02.03.2022 08:33
Водном из изданий книги л.н. толстого «война и мир» 1024 страницы. какой объём памяти (в мбайт) заняла бы эта книга, если бы лев николаевич набирал её на компьютере...
sonyapanferova
02.03.2022 08:33
Дан целочисленный массив из 30 элементов. элементы массива могут принимать значения от -1000 до 1000. опишите на языке программирования (паскаль) алгоритм, который...
Даша5432111
02.03.2022 08:33
Внекотором каталоге хранился файл ландыш.dос. в этом каталоге создали подкаталог май и файл ландыш.dос переместили в созданный подкаталог. полное имя файла стало...
МикаАбакирова
02.03.2022 08:33
Укакого слова есть суффикс «оньк» и окончание «ого». ....
куангы8789уш
02.03.2022 08:33
Водном из изданий книги л.н. толстого «война и мир» 1024 страницы. какой объём памяти (в мбайт) заняла бы эта книга, если бы лев николаевич набирал её на компьютере...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a,i,n,s:integer;
begin
write('Сколько чисел будет введено? - ');
readln(n);
s:=0;
for i:= 1 to n do
begin
readln(a);
if a mod 6=0 then s:=s+a;
end;
writeln('Сумма чисел кратных 6 = ', s);
end.