Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
kolzov
27.03.2022 01:13 •
Информатика
Составить программу pascal: вводят число от 1-12 -номер если число входит в интервал от 1 до 12, то высвечивается месяц, а если нет то выходит слово !
Ответ:
KetrinDark
18.06.2020 23:41
Var months: array [1..12] of string;
x: integer;
begin
months[1] := 'January';
months[2] := 'February';
months[3] := 'March';
months[4] := 'April';
months[5] := 'May';
months[6] := 'June';
months[7] := 'July';
months[8] := 'August';
months[9] := 'September';
months[10] := 'October';
months[11] := 'November';
months[12] := 'December';
read(x);
if ((x < 1) or (x > 12)) then begin
write('Error!');
end else begin
write(months[x]);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nastya2737
02.04.2021 02:33
В Excel не могу таблицу заполнить, надо написать -8,50, а оно автоматом 8,5 ставит...
CasDavis
04.01.2021 21:22
1) Что такое 3D- графика? Какие здесь есть измерения? 2) Какие программы для 2D- и 3D- графики вы знаете?3) Что за программа SketchUp? Как ее запустить?4) Какой шаблон нужно выбрать...
OkumRin
04.01.2021 21:22
Мощность алфавита N=33. Каĸое ĸоличество информации несет одна буĸва?...
slothy
22.09.2020 07:43
Первое и второе учебное задание ...
tanysha29
16.02.2023 14:36
. ответь на вопросы 1-5 из раздела «Размышления о прочитанном»...
salbekov201
19.02.2023 19:25
Вычислите чему равняется значение переменной с на выходе алгоритма: a = 4 b = 8 c = a + b b = 2 * (b + a) если b - a c то a + b * 2 / a - 7 иначе с = b - b / 3 * a + 12...
талифа4
18.02.2020 03:04
Выполните вычисления по блок – схеме для числа Х = 63. Запишите ответ....
zohvav
11.10.2022 08:08
Верное обозначение столбца в электронной таблице ... AB R13 56 13U...
uhon1k
30.03.2023 15:47
Сколько бит памяти занимает чёрно-белое изображение (без градаций серого) шириной 700 точек и высотой 60 точек?...
макс3094
30.03.2023 15:47
класс Составьте план разработки презентации. a.Подобрать фотографии и рисунки. b.Подобрать музыку или видео. c.Оформить презентацию. d.Настроить анимацию и навигацию. e.Определить...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
x: integer;
begin
months[1] := 'January';
months[2] := 'February';
months[3] := 'March';
months[4] := 'April';
months[5] := 'May';
months[6] := 'June';
months[7] := 'July';
months[8] := 'August';
months[9] := 'September';
months[10] := 'October';
months[11] := 'November';
months[12] := 'December';
read(x);
if ((x < 1) or (x > 12)) then begin
write('Error!');
end else begin
write(months[x]);
end;
end.