В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
патося37
патося37
01.08.2021 13:13 •  Информатика

Написать программу в PascalABC.net:

У трёх 6-значных чисел найти:

- произведение нечётных цифр

Ответ:
nunim
nunim
30.04.2021 22:16

var

pr1,pr2,pr3,a,b,c : integer;

begin

readln(a,b,c);

a := abs(a);

b := abs(b);

c := abs(c);

pr1 := 1;

pr2 := 1;

pr3 := 1;

while (a > 0) and (b > 0) and (c > 0) do

begin

if (a mod 10)mod 2 <> 0 then

pr1 := pr1 * (a mod 10);

a := a div 10;

if (b mod 10)mod 2 <> 0 then

pr2 := pr2 * (b mod 10);

b := b div 10;

if (c mod 10)mod 2 <> 0 then

pr3 := pr3 * (c mod 10);

c := c div 10;

end;

writeln(pr1,' ', pr2,' ',pr3);

end.

0,0(0 оценок)
Ответ:
denisfilin2
denisfilin2
30.04.2021 22:16

## uses School;

var P: integer -> integer := x -> x.Digits.Where(d -> d.IsOdd).Product;

ReadArrInteger(3).Select(n -> P(n)).Print


Написать программу в PascalABC.net:У трёх 6-значных чисел найти:- произведение нечётных цифр
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?