В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Баэхич
Баэхич
24.07.2020 16:11 •  Информатика

Дан целочисленный массив из 40 элементов. Напишите программу на паскале, которая находит и выводит пару с наименьшей суммой среди непересекающихся пар соседних элементов. То есть первая пара - 1 и 2 элементы, а вторая пара - 3 и 4 элементы и тд

Ответ:
Марс2014
Марс2014
30.04.2021 06:35

Объяснение:

Дан целочисленный массив из 40 элементов. Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно. Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит пару с наименьшей суммой среди непересекающихся пар соседних элементов. То есть, первая пара - 1-й и 2-й элементы, вторая пара - 3-й и 4-й элементы, и т.д.

Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.

0,0(0 оценок)
Ответ:
vika22888535
vika22888535
30.04.2021 06:35

числа задаются автоматом через  random

Объяснение:

var

 a : array [1..40] of integer;

 i, m, ind : integer;

begin

 randomize;

 for i := 1 to 40 do begin

   a[i] := random(100);

   if i mod 2 = 0 then write(a[i]:2, ' ')

   else write(a[i]:2, '__');

   if i mod 10 = 0 then writeln();

 end;

 m := 200;

 ind := -1;

 i := 1;

 repeat begin

   if m > (a[i]+a[i+1]) then begin

     m := (a[i]+a[i+1]);

     ind := i;

   end;

   i := i+2;

 end

 until i > 40;

 

 writeln('----- ', round((ind+1)/2) ,' пара минимальная -----');

 writeln(a[ind], ' ', a[ind+1]);

end.


Дан целочисленный массив из 40 элементов. Напишите программу на паскале, которая находит и выводит п
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?