В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
fofanchuk
fofanchuk
08.02.2021 21:11 •  Информатика

С клавиатуры вводят целые числа. Написать программу, которая рассчитывает сумму чисел больших 20; среднее арифметическое значение нечетных чисел. Количество чисел
вводят с клавиатуры.

Ответ:
360Polina360
360Polina360
29.04.2021 11:51

на Free Pascal

Объяснение:

var

 a : integer;

 n, i, big, nc, ncount  : integer;

begin

 writeln('Введите количество чисел :');

 readln(n);

 big := 0;

 nc := 0;

 ncount := 0;

 for i := 1 to n do begin

   writeln('Введите ', i, ' число:');

   readln(a);

   if a>20 then

     big := big + a;

   if (a mod 2) <> 0 then begin

     nc := nc + a;

     inc(ncount);

   end;

  end;

 writeln('Сумма чисел > 20 = ', big);

 writeln('Среднее арифметическое ',ncount,' нечётных чисел =', nc/ncount:2:2);

end.

0,0(0 оценок)
Ответ:
Piralta11
Piralta11
29.04.2021 11:51

sum = sum_odd = k = 0

mass = [int(input('введите элемент массива: ')) for s in range(int(input('введите n: ')))]

for i in range(len(mass)):

   if mass[i] > 20:

       sum += mass[i]

   if mass[i] % 2:

       sum_odd += mass[i]

       k += 1

average = sum_odd / k

print(sum, average)

Объяснение:

на Питоне

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?