В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Andreyvko1
Andreyvko1
28.08.2020 11:59 •  Информатика

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры 5-значное число и определять, является ли число палиндромом. Палиндром — число (или слово), которое
одинаково "читается" слева направо и справа налево. Например, число 12321 –
палиндром, а число 12345 — нет.
На вход программы подаётся 5-значное натуральное число (проверку корректности ввода
проводить не надо), на выходе должно появиться одно слово - Yes, если число является
палиндромом, и No, если нет.
Вспомните разговор о типах данных! В этой задаче число 5-значное, оно может быть
больше 32767. В некоторых версиях Pascal такое число не может быть описано как
integer. Поэтому для корректной работы программы входное число следует описать
Kax longint.​


Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры 5-значное число и определять

Ответ:
bochar2001roody
bochar2001roody
29.04.2021 10:51

всё ещё проще. будем считать число строкой символов. И если первый и последний и второй и предпоследний символы равны - то это и будет палиндром. Прикольно что это будет работать и со строковыми данными - словами   :))

Объяснение:

var

 s : string;

begin

 readln(s);

 writeln('');

 if (s[1]=s[5]) and (s[2]=s[4]) then

   writeln('Yes')

 else

   writeln('no')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?