В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mastervydy
mastervydy
10.08.2020 07:38 •  Информатика

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры 4-значное число и определять, является ли число счастливым или нет. Счастливое число — это такое, у
которого сумма первых двух цифр равна сумме двух последних. Например, число 1230 —
счастливое, а 1234 — нет.
На вход программы подаётся четырёхзначное натуральное число (проверку корректности
ввода проводить не надо), на выходе должно появиться одно слово - Yes (с заглавной
буквы!), если число счастливое, и No, если нет.​


Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры 4-значное число и определять

Ответ:
dalldall
dalldall
29.04.2021 10:38

var A,s1,s2: integer;

begin

   write('Введите число: '); readln(A);

   

   s1 := (A div 1000) + (A div 100) mod 10;

   s2 := (A div 10) mod 10 + A mod 10;

   

   if s1 = s2 then writeln('Yes')

   else writeln('No');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?