В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
andrekunshin
andrekunshin
13.09.2022 09:25 •  Информатика

нужно, заранее ) Составить алгоритм через программу С++
 дано трехзначное целое число. Составить программу, которая определяет, является ли произведение цифр числа двузначным числом;
 дано четырехзначное число. Составить программу, которая определяет, какие цифры этого числа четные, а какие нечетные. Число вводить с клавиатуры;
 составить программу, которая определяет, делится ли одно целое число на другое без остатка. Числа вводить с клавиатуры.

Ответ:
малика225
малика225
25.04.2021 08:10

//1

#include <iostream>

using namespace std;

signed main() {

int N, pr = 1;

cin >> N;

N = abs(N);

if ((N % 10 * (N / 10) % 10 * N / 100) > 10 and (N % 10 * (N / 10) % 10 * N / 100) < 100)

 cout << "YES";

else

 cout << "NO";

return 0;

}

//2

#include <iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int N;

cin >> N;

N = abs(N);

while (N > 0) {

 if ((N % 10) % 2 == 0)

  cout << N % 10 << " - четное\n";

 else

  cout << N % 10 << " - нечетное\n";

 N /= 10;

}

return 0;

}

//3

#include <iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int a, b;

cin >> a >> b;

if (a % b == 0)

 cout << "Число " << a << " делится без остатка на число " << b;

else

 cout << "Число " << a << " не делится без остатка на число " << b;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?