В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Андрей15777
Андрей15777
05.11.2020 00:49 •  Информатика

Составьте программу, вводящую true, если высказывание является истинным, и false в противном случае: а) сумма цифр трёхзначного числа х является чётным числом;
б) треугольник со сторонами a, b, c является разносторонним.
))) СОСТАВЬТЕ ПРОГРАММУ В ПАСКАЛЕ ​

Ответ:
darkhun
darkhun
24.04.2021 08:22

a)

var

a, sum, i : integer;

begin

readln(a);

sum:=0;

while a > 0 do begin

sum:= sum + (a mod 10);

a:= a div 10;

end;

writeln((sum mod 2) = 0);

end.

б)

var

a, b, c: integer;

res: boolean;

begin

readln(a, b, c);

res := (a <> b) and (a <> c) and (b <> c);

writeln(res);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?