В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
leonkrotovv
leonkrotovv
10.06.2020 19:14 •  Информатика

Составить программу для перевода суммы из долларов в рубли. Вводиться текущий курс доллара и сумма в долларах. Результат должен выводиться в денежном формате 345 РУБ 40 КОП ПАСКАЛЬ

Ответ:
zifu
zifu
24.04.2021 07:32

var

kurs, summa, rub: double;

begin

readln(kurs, summa);

rub := kurs * summa;

writeln(trunc(rub), ' РУБ ', (frac(rub) * 100):2:0, ' КОП');

end.

Объяснение:

Получаем два числа, затем перемножаем курс на сумму в долларах, чтобы получить рубли и затем выводим в нужном формате.  

trunc(a) получает целую часть от числа  

frac(a) получает дробную часть от числа, затем умножаем на 100 для преобразования дробной части в целую(для вывода на экран) (например число 0.22 преобразуется в 22.0) и с :2:0 выводим в формате 2 цифры до запятой и 0 после.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?