В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ЛенаКошка
ЛенаКошка
19.03.2021 23:04 •  Информатика

Дан массив a из n элементов. Скопировать в новый массив элементы массива а превышающие число k. Реализовать функцию для копирования этих элементов в отдельный массив.

Формат входных данных
0 < n < 100 - количество элементов массива

n элементов массива записанные через пробел. (0 < a[i] < 100)

0 < k < 100

Формат выходных данных
Вывести элементы массива превышающие k

Ответ:
karolinamurzak
karolinamurzak
23.04.2021 13:10

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

int N, k;

cin >> N;

vector<int> a(N, 0);

for (int i = 0; i < N; i++)

 cin >> a[i];

cin >> k;

for (int i = 0; i < N; i++)

 if (a[i] > k)

  cout << a[i] << " ";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?