В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dashkaborisova
dashkaborisova
01.11.2022 20:09 •  Информатика

Программа получает на вход последовательность целых неотрицательных чисел. Ноль – признак конца. Поменять местами минимальный и максимальный элементы. Если максимальных и/или минимальных элементов несколько, то брать в расчёт первое вхождение. Sample Input 1:
1
8
2
13
0

Sample Output 1:
13
8
2
1

Sample Input 2:
1
1
5
2
5
0

Sample Output 2:
5
1
1
2
5

Программу написать в Python.

Ответ:
darinaavans
darinaavans
19.03.2021 19:20

n = int(input())

mass = []

mx = 0

mn = n

while n != 0:

   mass.append(n)

   if n > mx:

       mx = n

   if n < mn:

       mn = n

   n = int(input())

mass[mass.index(mx)], mass[mass.index(mn)] = mass[mass.index(mn)], mass[mass.index(mx)]

print(mass)

Объяснение:

замену максимума на минимум

mass[mass.index(mx)], mass[mass.index(mn)] = mass[mass.index(mn)], mass[mass.index(mx)]

можно записать так

i = mass.index(mx)

j = mass.index(mn)

mass[i], mass[j] = mass[j], mass[i]

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?