В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Scruff17
Scruff17
05.06.2023 05:31 •  Информатика

Напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n: integer): integer; var p,i: integer; begin p: =1; for i: =1 to n do p: =p*i; factorial: =p; end;

Ответ:
Arisha5554
Arisha5554
18.06.2020 16:16
Var n:integer;
      ch:char;
function factorial (n:integer):longint;
  var p,i:integer; 
  begin 
    p:=1;
    for i:=1 to n do p:=p*i; 
    factorial:=p;
end;
begin
    write ('N = ');
    readln (n);
    writeln ('Factorial: ',factorial(n));
    readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?