В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vikaos01Vi
vikaos01Vi
14.03.2022 12:12 •  Информатика

В питоне написать программу: 1. Дано предложение. Создать множество, содержащее буквы, которых нет в этом
предложении.
2. Заданы имена девочек. Определить, какие из этих имен встречаются во всех
классах данной параллели, которые есть только в некоторых классах и какие из
этих имен не встречаются ни в одном классе.

Ответ:
Begkakaaa
Begkakaaa
17.04.2021 18:36

1:

s = 'Это некоторое предложение'

a = ord('а')

chars = [rrchr(i) for i in range(a,a+34) if not rrchr(i) in s and i != a+32]

print(chars)

2:

parallel = [('имя1','имя2','имя3','имя4'),('имя1','имя2','имя5'),('имя2','имя4')]

names = ['имя1','имя2','имя3','имя4','имя5','имя6']

presence = []

for name in names:

 counter = 0

 for klass in parallel:

   for person in klass:

     if person == name:

       counter += 1

       break

 presence.append((name,counter))

for name in presence:

 print(name[0],'-',

       'встречаются во всех классах данной параллели' if name[1] == len(parallel)

       else 'есть только в некоторых классах' if name[1] != 0

       else 'не встречаются ни в одном классе')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?