В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
madinatrtyakov
madinatrtyakov
12.12.2022 17:06 •  Информатика

С++

Циклический сдвиг
Напишите программу, которая будет циклически сдвигать заданный массив на один элемент вправо, последний элемент при этом должен оказаться на первом месте.

Входные данные

На вход программе сначала подается значение n≤100 — количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива — натуральные числа, не превосходящие 100.

Выходные данные

Выдайте значения элементов массива после выполнения указанной операции.

Примеры
Ввод
Вывод
5
8 7 4 8 3
3 8 7 4 8

Ответ:
FedorShar28
FedorShar28
16.04.2021 15:13

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n, a, k, b, i;

   cin >> n;

   vector<int> v(n);// создаём вектор из n чисел

   for (int i = 0; i < n; ++i){

       cin >> v[i];

   }

   cout << v[n - 1];

   for(int i = 0; i < n - 1; ++i){

       cout << ' ' << v[i];  

   }

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?