В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Evg120058
Evg120058
13.11.2021 08:12 •  Информатика

На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел. Решить в Python.

Ответ:
darkhanio
darkhanio
16.04.2021 14:29

a = [0]*9

while True:

 x = int(input('Введите цифру от 1 до 9: '))

 if x == 0: break

 if 1 <= x <= 9: a[x-1]+=1

for i in enumerate(a):

 print(f'{i[0]+1}: {i[1]}')

0,0(0 оценок)
Ответ:
Shmops1063
Shmops1063
16.04.2021 14:29

count = 0

m = [0]*9

while count <= 100000:

   a = int(input())

   if a == 0:

       break

   elif 1 <= a <= 9:

       m[a-1] += 1

   count += 1

   

print(*m)  #

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?