В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vlad87456
vlad87456
21.02.2021 09:42 •  Информатика

Информатика плз составить программу в ПАСКАЛЕ: Найти сумму чисел от 1 до n двумя

Ответ:
Alexal16
Alexal16
15.04.2021 17:05

№1: с цикла for

program s1;

var N,S,i:integer;

BEGIN

writeln('Нахождение суммы чисел от 1 до n');

write('Введите число: ');

readln(N);

for i:=1 to n do

S:=S+i;

writeln('Сумма чисел равна: ', s);

END.

№2: с формулы суммы арифметической последовательности S_{n}=\frac{a_{1}+a_{n} }{2} *n

program s2;

var N,i:integer;

S:real;

BEGIN

writeln('Нахождение суммы чисел от 1 до n');

write('Введите число: ');

readln(N);

S:= ( (1 + n)/2 )*N;

writeln('Сумма чисел равна: ', s);

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?