В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DashaLatysheva1
DashaLatysheva1
30.03.2023 03:01 •  Информатика

Нужно на С++ с контейнера vector Цифры
На вход программе подается последовательность из N чисел от 1 до 9. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат.

Входные данные

В первой строке записано натуральное число N (N≤100) — количество элементов в последовательности. В следущей строке записано N целых чисел от 1 до 9 — элементы последовательности.

Выходные данные

Выведите ответ на задачу.

Ответ:
умница06092006
умница06092006
15.03.2021 22:50

#include <iostream>

#include <vector>

using namespace std;

int main(){

   vector<int> m(10,0);

   int n,x;

   cin >> n;

   while(n--){

       cin >> x;

       m[x]++;

   }

   for(int i = 1; i <= 9; i++)

       cout << m[i] << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?