В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Angelaby
Angelaby
28.01.2020 00:23 •  Информатика

Написать программу, которая получает возраст человека от 0 до 120 лет и выводит со словом "год", "года", "лет".

Ответ:
kakaxa6
kakaxa6
18.06.2020 09:51
Ищем закономерности.

Год: 1, 21, 31, 41, 51, 61, 71, 81, 91, 101
(оканчивается на единицу, исключение: 11 и 111)
Года: 2-4, 22-24, 32-34, 42-44, 52-54, 62-64, 72-74, 82-84, 92-94, 102-104
(оканчивается на 2, 3 или 4, исключения: 12, 13, 14, 112, 113, 114)
Лет: 0, 5-20, 25-30, 35-40, 45-50, 55-60, 65-70, 75-80, 85-90, 95-100, 105-120
(оканчивается на 0, 5-9, плюс исключения из пунктов)
У исключений есть общее: остаток при делении на 100 будет в промежутке от 11 до 14.

n - возраст
Язык программирования: Паскаль

var
n : integer ;
begin
read (n) ;
n := n mod 100 ;
if n in [11..14] then
writeln ('лет');
else
begin
n := n mod 10 ;
case n of
1 : writeln ('год') ;
2..4 : writeln ('года') ;
0, 5..9 : writeln ('лет') ;
end ;
readln ;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?