В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kristinaalekse1
kristinaalekse1
26.11.2022 02:23 •  Информатика

Напишите программу на C ++, чтобы найти третий угол треугольника. Введите 1-й угол треугольника: 30
Введите 2-й угол треугольника: 60​

Ответ:
danilsartakov
danilsartakov
14.03.2021 11:20

#include<iostream>

#include<iomanip>

#define _USE_MATH_DEFINES

#include<cmath>

using namespace std;

 

int main()

{

   double a, b, c, alfa, beta, gamma;

   

   cout <<"a="; cin >> a;

   cout <<"b="; cin >> b;

   cout <<"c="; cin >> c;

   

   if (a+b>c && a+c>b && b+c>a)

   {    

   alfa = acos((b*b+c*c-a*a)/(2*b*c))*180/M_PI;

   beta = acos((a*a+c*c-b*b)/(2*a*c))*180/M_PI;

   gamma = acos((a*a+b*b-c*c)/(2*a*b))*180/M_PI;    

   cout <<"Angles in degrees:\n";

   cout <<setprecision(3)<<fixed<< "alfa=" << alfa << " beta=" << beta << " gamma=" << gamma << endl;

   }

   else cout << "Triangle absent\n";

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?