В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ludamechta
ludamechta
25.04.2021 06:07 •  Информатика

Напишите программу в паскале!
2 программы. Номер 7 и 8!


Напишите программу в паскале! 2 программы. Номер 7 и 8!
Напишите программу в паскале! 2 программы. Номер 7 и 8!
Напишите программу в паскале! 2 программы. Номер 7 и 8!

Ответ:
vovsanna
vovsanna
08.03.2021 16:10

Объяснение:

честно, незнаю, правильно ли, если нужно ещё чем нибудь


Напишите программу в паскале! 2 программы. Номер 7 и 8!
0,0(0 оценок)
Ответ:
Niknik00i1
Niknik00i1
27.01.2024 20:45
Конечно, я помогу вам с написанием программы в Паскале для задачи номер 7 и 8.

Программа для задачи номер 7:

```Pascal
program Task7;

var
number, sum: integer;

begin
sum := 0;

writeln('Введите число:');
readln(number);

while number <> 0 do
begin
sum := sum + (number mod 10);
number := number div 10;
end;

writeln('Сумма цифр числа:', sum);

end.
```

Объяснение:
Программа вычисляет сумму цифр заданного числа. Начиная с инициализации переменных `number` и`sum` типа `integer` и равными нулю, программа затем запрашивает ввод числа от пользователя. Затем, используя цикл `while`, программа суммирует каждую цифру числа, начиная с последней. Для этого используются операторы деления на 10 и остаток от деления на 10 (`mod` и `div`). Результат суммирования выводится на экран.

Программа для задачи номер 8:

```Pascal
program Task8;

var
number, reversedNumber, remainder: integer;

begin
reversedNumber := 0;

write('Введите число: ');
readln(number);

while number <> 0 do
begin
remainder := number mod 10;
reversedNumber := reversedNumber * 10 + remainder;
number := number div 10;
end;

writeln('Перевернутое число:', reversedNumber);

end.
```

Объяснение:
Программа переворачивает заданное число. Процесс начинается с инициализации переменных `number` и `reversedNumber` типа `integer` равными нулю. Затем программа запрашивает ввод числа от пользователя. Затем, используя цикл `while`, программа берет остаток от деления числа на 10 (`remainder`) и добавляет его в конец `reversedNumber`, умноженный на 10 (для смещения цифр влево). Затем программа делит число на 10 (`number div 10`), чтобы исключить последнюю обработанную цифру. Процесс повторяется, пока число не станет равным 0. В конце программа выводит результат - перевернутое число - на экран.

Надеюсь, это поможет вам с написанием программ в Паскале для задачи номер 7 и 8! Если у вас возникнут еще вопросы, пожалуйста, дайте мне знать.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?