В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
TOLIK474747
TOLIK474747
06.03.2020 03:44 •  Информатика

Pascal Ниже записан алгоритм. Сколько существует таких чисел `x`, при вводе которых алгоритм печатает сначала `6`, а потом `27`? Что делает данная программа? Какие это числа? Объясните свои ответы.
var x, a, b: longint;
begin
readln(x);
a:=0; b:=1;
while x>0 do begin
a:=a + 1;
if a mod 2 =0 then
b:=b*(x mod 10);
x:=x div 10;
end;
writeln(a); write(b);
end.

Ответ:
TFestFlyMan
TFestFlyMan
06.04.2021 16:33

а не проще на типе интеджер

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?