В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Акали
Акали
23.03.2021 13:29 •  Информатика

Написать программу на С++ с любым из циклов. Задачи:
1) Каждый день в огороде созревают огурцы по 5 штук. Сколько будет огурцов через месяц?
2) На изготовление ювелирного изделия требуется 5 граммов золота. Сколько Украшений получиться из 3037 грамм?

Ответ:
Ониг
Ониг
04.04.2021 16:50

1)

#include <iostream>

using namespace std;

int main()

{

   cout << 5 * 30 << endl;

   return 0;

}

2)

#include <iostream>

using namespace std;

int main()

{

   cout << 3037 / 5 << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
GoldenFreddi322
GoldenFreddi322
04.04.2021 16:50

#include <iostream>

using namespace std;

int Vegetables(int month)

{

int cucumbers = 0;

for (int i = 0; i < month; i++)

{

 cucumbers += 5;

}

return cucumbers;

}

int decoration(int gold_amount, int gold_per_decoration)

{

int decor = 0;

while (gold_amount > 0)

{

 decor++;

 gold_amount -= gold_per_decoration;

}

return decor - 1;

}

int main()

{

setlocale(LC_ALL, "rus");

int month = 30, gold_amount = 3037, gold_per_decoration = 5;

 

cout << "В месяц, длинною в 30 дней, созревает " << Vegetables(month) << " огурцов" << endl;

cout << "Из " << gold_amount << " грамм золота, можно получить " << decoration(gold_amount, gold_per_decoration) << " украшений" << endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?