В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на языке паскаль. вводятся размер и элементы одномерного массива a(n), состоящего из целых чисел. подсчитать сумму простых чисел, оканчивающихся на 3. результат вывести на экран.

Ответ:
М4ш4
М4ш4
17.06.2020 22:33

uses crt;
Var a:array [1..100] of integer; i,n,s: integer;
Begin

Writeln('Введите размер массива'); readln(n);

For i:=1 to n do begin
                    writeln('Введите элемент массива номер  ',i); read(a[i]);
                 end;

For i:=1 to n do
    if a[i] mod 10=3 then s:=s+a[i];
    
Writeln('Сумма = ',s);

end.

 

Написано через PascalABC. Если используете другой паскаль вместо первой строчки пишите "Program 123;"

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?