В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
RomcheG3228
RomcheG3228
04.05.2022 03:14 •  Информатика

2. Запишите программный код к задаче. Дано вещественное число A и целое число N (>0).Составьте программу, которая выводит все целые степени числа A от 1 до N.

Ответ:
PAVELBOR
PAVELBOR
04.03.2021 06:00

С++

#include <iostream>  

using namespace std;

int main()

{

   int A;  //Вводим число А целого типа

   int N;  //Вводим число N целого типа

   cin>>A>>N;  //Вводим значения чисел с клавиатуры

   for(int i = 1; i<=N; ++i)  //Выполняем цикл от 1 до числа N

   {

       for(int j = 1; j<i; ++j)  //Выполняем цикл от 1 до i

           A*=A;  //Умножаем число А на самого себя по определению степени

       cout<<A<<endl; //Выводим число А

   }

   return 0;  

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?