В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Склавиатуры вводятся n чисел. составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. значение n и сами числа вводится с клавиатуры.

Ответ:
barsik20002
barsik20002
01.10.2020 07:15

var

  n,o,p,k,i:integer;

  a:real;

begin

 repeat

   write ('N = ');readln(n);

 until (n>0);

 i:=0; 

 k:=0;

 p:=0;

 o:=0;

 repeat

   write ('Ввод: ');readln(a);

   i:=i+1;

   if a<0 then o:=o+1 else

    if a>0 then p:=p+1 else k:=k+1;

 until i=n;

 writeln ('Кол-во положительных: ',p);

 writeln ('Кол-во отрицательных: ',o);

 writeln ('Кол-во нулей: ',k);

 readln;

end.

0,0(0 оценок)
Ответ:
alnoskoff
alnoskoff
01.10.2020 07:15

program aa;
var minus, plus, zero, N, C, Q : integer;
begin
zero:=0;
plus:=0;
minus:=0;
C:=0;
writeln('Введите количество чисел);
read(N);
writeln('Вводите числа');
while C<N do begin
read(Q);
C:=C+1;
If Q=0 then zero:=zero+1;
If Q<0 then minus:=minus+1;
If Q>0 then plus:=plus+1;
end;
writeln('Нулей: ',zero);
writeln('Отрицательных: ',minus);
writeln('Положительных: ',plus);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?