В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DianaMiss05
DianaMiss05
24.06.2020 23:17 •  Информатика

Написать программу которая проверяет находится ли в массиве введенное с клавиатуры число. массив должен вводиться случайным образом(pascal)

Ответ:
Sofka11123
Sofka11123
17.06.2020 20:23

В массиве n элементов.
Случайным образом вводятся целые числа от 0 до 999.
x - ведённое с клавиатуры число.
i - цикловая переменная.

var
a : array [1..100] of integer;
x, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
readln (x);
for i := 1 to n do
if a [ i ] := x then
writeln ('введённое с клавиатуры число находится в массиве');
end.

Если количество элементов в массиве известно изначально, например 25,  тогда строку " readln (n); " убираете, а строки
" for i := 1 to n do "
заменяете на
" for i := 1 to 25 do "

Минус данной программы: если введённое с клавиатуры число не находится в массиве, то программа ничего не выводит.

0,0(0 оценок)
Ответ:
Агентство10203040
Агентство10203040
17.06.2020 20:23

var

  a:array [1..100] of integer;

  i,n,k:integer;

  f:boolean;

begin

  write ('Razmer massiva (N<100): ');readln(n);

  for i:=1 to n do begin

    a[i]:=random(36)-10;

    write (a[i],' ');

  end;

  writeln; 

  write ('Number: ');readln(k);

  f:=false;

  for i:=1 to n do

    if a[i]=k then f:=true; 

  writeln (f);

  readln;

end.

Выводит FALSE, если в масиве нет числа,иначе выводит TRUE.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?