В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
02.06.2022 10:37 •  Информатика

Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива

Ответ:
dzhele19
dzhele19
17.06.2020 20:26

Случайным образом вводятся целые числа от 0 до 999.
max - максимальный элемент массива
i - цикловая переменная.

var
a : array [1..100] of integer;
max, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
max :=  a [ 1 ];
for i := 2 to n do
if a [ i ] > max then
max :=  a [ i ];
writeln (max + a [ 1 ])
end.

0,0(0 оценок)
Ответ:
Makc134
Makc134
17.06.2020 20:26

uses crt;

var
  a:array [1..1000] of integer;
  max,i,k:integer;
begin
  write('Введи количество элементов массива: '); read(k);
  for i:=1 to k do
  begin
    a[i]:=random(100)-50;
    write(a[i]:4);
  end;

  writeln;
  max:= a[1];
  for i:=1 to k do
    if a[i]>max then max:=a[i];
  writeln('Максимальный элемент: ',max);
  writeln ('Сумма первого и максимального элементов: ',max+a[1])
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?