В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vil67
Vil67
12.02.2020 04:46 •  Информатика

Написать программу на паскале: в целочисленном одномерном массиве из n(n< =50)элементов.найти номера элементов кратных 3.если таких элементов нет, то сообщить об этом.массив заполнить вручную.

Ответ:
кпо123
кпо123
01.10.2020 06:34

Program Natasha1925;
uses crt;
const n=50;
var
 a:array[1..n] of integer;
 tri:array[1..n] of integer;
 nom,i: integer;
  begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  nom:=0;
  for i:=1 to n do
  begin
    write('Введите ',i,'-e число ');
    readln(a[i]);
    if a[i] mod 3 = 0 then
      begin
        nom:=nom+1;
        tri[nom]:=i;
      end;
   end;
  if nom = 0 then
      writeln('Элементов, кратных 3, нет!: ')
    else
      begin
        writeln('Номера элементов, кратных 3: ');
        for i:=1 to nom do
          begin
            write(tri[i],' ');
          end;
      end;
   writeln();
end.

0,0(0 оценок)
Ответ:
ШАТАНТРУБА
ШАТАНТРУБА
01.10.2020 06:34

uses crt;
var
  a:array[1..50] of integer;
  i,n,k:integer;
begin
  clrscr;

  k:=0;
  write('Введите количество элементов массива'); read(n);
  writeln('Введите массив:');
  for i:=1 to n do
    read(a[i]);
  write('Номера элементов, кратных 3:');
  for i:=1 to n do

    if (a[i] mod 3=0) then
    begin
      k:=k+1;
      write(i,' ');
    end;
  if k=0 then write('Таких элементов нет.');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?