В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
flexELITE3
flexELITE3
25.02.2020 21:16 •  Информатика

Си++ составить программу, вычисляющую и выводящую все члены числового ряда 1, 1/2! ,1/3! , …,1/n! , значение которых превышает 10-5.

Ответ:
Viktorua10
Viktorua10
01.10.2020 06:26

#include<iostream>

using namespace std;
long double fac(int N)
{
if(N < 0) // если пользователь ввел отрицательное число
return 0; // возвращаем ноль
if (N == 0) // если пользователь ввел ноль,
return 1; // возвращаем факториал от нуля - не удивляетесь, но это 1 =)
else // Во всех остальных случаях
return N * fac(N - 1); // делаем рекурсию.
}
int main()

{
int N;
cout << "enter N: " ;
cin >> N;
for(int i = 0; i < N; i++)
cout << "a[ " << i << " ] = " << 1/fac(i) << endl;
}

 

данная программа вычисляет  значения ряда, до N-го члена ряда

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?