В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
новичок586
новичок586
04.02.2020 02:33 •  Информатика

Составить программу для turbo pascal. дано 2 круга с общим центром и радиусами r1 и r2 (r1> r2).найти площадь этих кругов s1 и s2,а также площадь кольца s3 ,наружный радиус которого равен r1,а внутренний радиус равен r2 ; s1=п(r1)^2, s2=п(r2)^2, s3=s1-s2. значение п=3.14

Ответ:
EvilHany
EvilHany
01.10.2020 06:23

Program irinagavrish;
const
  pi = 3.14;
Var
  r1,r2,s1,s2,s3:real;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  write('Введите радиус первой окружности: ');readln(r1);
  write('Введите радиус второй окружности: ');readln(r2);
  s1:=pi*r1*r1;
  s2:=pi*r2*r2;
  s3:=abs(s1-s2);
  writeln('Площадь первого круга: ',s1:7:2);
  writeln('Площадь второго круга: ',s2:7:2);
  writeln('Площадь кольца: ',s3:7:2);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?