В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
linagurova6545
linagurova6545
30.04.2023 03:55 •  Информатика

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры слово Ѕ, состоящее из 4 букв, и выполняет с ним следующие операции:
a) выводит отдельные символы слова по одному на каждой строке - сначала
первый символ, затем второй и так далее,
b) выводит отдельные символы слова по одному на каждой строке - сначала
последний символ, затем - предпоследний и так далее,
с) формирует новое слово S1, которое получается из исходного чтением
символов справа налево, например, из слова арба должно получится слово
абра, а из слова аbcd - dcba. Обратите внимание: новое слово должно быть
сформировано и храниться в памяти компьютера, недостаточно просто
вывести переставленные буквы на экран.
d) формирует новое двухбуквенное слово S2, состоящее из первой и
последней буквы исходного слова.​

Ответ:
ксения23242526
ксения23242526
30.03.2021 20:37

var

 i:integer;

 s,str,newWordOne,newWordTwo:string;

begin

 writeln('введите слово');

 readln(s);

 writeln;

 for i:=1 to length(s) do begin

   newWordOne:=newWordOne+s[i];

   writeln(s[i]);

 end;

 writeln;

   writeln(newWordOne);

  writeln;

  for i:=length(s) downto 1 do begin

   newWordTwo:=newWordTwo+s[i];

   writeln(s[i]);

  end;

  writeln;

  writeln(newWordTwo);

  writeln;

  str:=s[1]+s[length(s)];

  writeln(str);

   readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?