В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Krasnovadiana11
Krasnovadiana11
04.02.2023 02:13 •  Информатика

Информатика. Питон. Программа #1 :
1) Введите свое имя:

б) выведите на экран 1-й и 3-й символы;

в) определите, совпадают ли 1-й и последний символы вашего имени.

Программа #2 :
2) Напишите программу, которая запрашивает ввод нескольких слов с клавиатуры, а затем определяет длину самого короткого слова в строке.

Ответ:
3108200614041976
3108200614041976
29.03.2021 07:35
1)

name = input("Имя: ").lower()

print("1-й и 3-й символы:", name[0],"и",name[2])

if name[0] == name[len(name)-1]:

    print("Совпадают ли 1-й и последний символы вашего имени:", "Да")

else:

    print("Совпадают ли 1-й и последний символы вашего имени:", "Нет")

 2)

s = [i for i in input().split()]

min = len(s[0])

for i in s:

    if len(i) < min:

        min = len(i)

print("Длина самого короткого слова: ",min)


Информатика. Питон. Программа #1 : 1) Введите свое имя:б) выведите на экран 1-й и 3-й символы;в) опр
Информатика. Питон. Программа #1 : 1) Введите свое имя:б) выведите на экран 1-й и 3-й символы;в) опр
0,0(0 оценок)
Ответ:
Littlelimegirl
Littlelimegirl
29.03.2021 07:35

# 1

name = input("name: ") .lower()

# б

print(name[0], name[2])

# в

if name[0] == name[-1]:

   print("Совпадает")

else:

   print("не совпадает")

# 2

mins = None

for i in range(5):

   a = input("Слово: ")

   if mins == None: mins = len(a)

   elif len(a) < mins: mins = len(a)

print(f"Длина самого короткого слово составляет {mins} символов")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?