В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BogYato
BogYato
26.03.2023 19:19 •  Информатика

Составить программу, которая выводит на экран меню: 1) первое; 2) второе; 3) третье; и в зависимости от выбранного пункта выдаёт одну из надписей: «получите суп», «получите картошку», «получите компот», «оставайтесь голодным». написать два варианта программы: с использованием условного оператора if и с использованием переключателя.

Ответ:
musmus11
musmus11
17.06.2020 10:23



Program Atatushka1;
uses crt;
var
  M:Integer;
begin
  writeln('');
  writeln('*    Мы рады приветствовать вас       *');
  writeln('*         в нашем ресторане           *');
  writeln('*         A T A T U S H K A           *');
  writeln('*               ! ! !                 *');
  writeln('');
  writeln();
  writeln('');
  writeln('*              М Е Н Ю :              *');
  writeln('*  1. Первое                          *');
  writeln('*  2. Второе                          *');
  writeln('*  3. Третье                          *');
  writeln('*                                     *');
  writeln('');
  writeln();
  writeln('Введите номер желаемого блюда:');
  readln(M);
  writeln();
  if m=1 then
      writeln('Получите суп')
    else
      if m=2 then
          writeln('Получите картошку')
        else
          if m=3 then
              writeln('Получите компот')
            else
              writeln('Оставайтесь голодным');
end.

Program Atatushka2;
uses crt;
var
  M:Integer;
begin
  writeln('');
  writeln('*    Мы рады приветствовать вас       *');
  writeln('*         в нашем ресторане           *');
  writeln('*         A T A T U S H K A           *');
  writeln('*               ! ! !                 *');
  writeln('');
  writeln();
  writeln('');
  writeln('*              М Е Н Ю :              *');
  writeln('*  1. Первое                          *');
  writeln('*  2. Второе                          *');
  writeln('*  3. Третье                          *');
  writeln('*                                     *');
  writeln('');
  writeln();
  writeln('Введите номер желаемого блюда:');
  readln(M);
  writeln();
  case m of
    1: writeln('Получите суп');
    2: writeln('Получите картошку');
    3: writeln('Получите компот');
    else writeln('Оставайтесь голодным');
  end;
end.

0,0(0 оценок)
Ответ:
angelnoya1
angelnoya1
17.06.2020 10:23

uses crt;
var m:integer;
begin
writeln('1) первое');
writeln('2) второе');
writeln('3) третье');
read(m);
if m=1 then write('получите суп');
if m=2 then write('получите картошку');
if m=3 then write('получите компот')
else write('оставайтесь голодным');
end.

 

uses crt;
var m:integer;
begin
writeln('1) первое');
writeln('2) второе');
writeln('3) третье');
read(m);
case m of
1:write('получите суп');
2:write('получите картошку');
3:write('получите компот');
else write('оставайтесь голодным');
end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?